Struts2 S2-057 远程代码执行-高危

技术 作者:知安 2018-08-26 17:01 阅读:1133 评论:0

漏洞Struts2 远程代码执行

CVE-ID:CVE-2018-11776

等级高危

细节

当没有为底层xml配置中定义的结果设置命名空间值时,同时其上层动作集配置没有或只有通配符命名空间值,可能会导致同时执行RCE攻击。

当使用URL标签,它没有值和动作集,同时它的上层动作集配置 没有或只有通配符命名空间值 ,同样可能会导致同时执行RCE攻击。

影响范围

Struts 2.3 - Struts 2.3.34

Struts 2.5 - Struts 2.5.16

修复方案

升级到Struts 2.3.35或Struts 2.5.17

来源:

https://cwiki.apache.org/confluence/display/WW/S2-057

Struts2

Struts2 S2-057 远程代码执行-高危-大发快3计划

Struts2是一个基于MVC设计模式的Web应用框架,它本质上相当于一个servlet,在MVC设计模式中,Struts2作为控制器(Controller)来建立模型与视图的数据交互。Struts 2是Struts的下一代产品,是在 struts 1和WebWork的技术基础上进行了合并的全新的Struts 2框架。其全新的Struts 2的体系结构与Struts 1的体系结构差别巨大。Struts 2以WebWork为核心,采用拦截器的机制来处理用户的请求,这样的设计也使得业务逻辑控制器能够与ServletAPI完全脱离开,所以Struts 2可以理解为WebWork的更新产品。虽然从Struts 1到Struts 2有着太大的变化,但是相对于WebWork,Struts 2的变化很小。


知安 知安
  • 知安(KnowSafe)是一个帮助站长、厂商、企事业单位、政府机关发现并解决安全风险问题的代码医院,创建于2015年,由国内最大互联网安全团队网络尖刀团队支撑。http://www.knowsafe.com
关注网络尖刀微信公众号
随时掌握互联网精彩
广告赞助